3 posts / 0 new
Last post
Update Quickbooks transaction address error
I'm trying to create a workflow that will update an existing Sales Order in Quickbooks from an Opportunity in SalesForce, but I'm having trouble with the billing and shipping address. The workflow I have that inserts a new Sales Order works fine, but if I use the same settings and the same data to update an existing Sales Order then it gives me an error. I have tried making the update in 2 different ways: <BillAddress> <Addr1>Company</Addr1> <Addr2>Person Name</Addr2> <Addr3>1234 Main St</Addr3> <Addr4>Los Angeles, CA 90745</Addr4> <Addr5>US</Addr5> </BillAddress> <BillAddress> <Addr1>Company</Addr1> <Addr2>Person Name</Addr2> <Addr3>1234 Main St</Addr3> <City>Los Angeles</City> <State>CA</State> <PostalCode>90745</PostalCode> <Country>US</Country> </BillAddress> The first version gives the error: "The &quot;address&quot; field has an invalid value &quot;&quot;. QuickBooks error message: The parameter is incorrect." The second version gives the error: "There is not enough address lines to compose the address." The most promising suggestion I've seen when researching this is to erase the address completely and then update it with the new address in a 2nd request. However, it doesn't seem that DBSync will allow empty values in the QBXML. If I enter an empty string into the address fields then those fields are just not included in the request at all. I have tried erasing the addresses manually in the QB Desktop app, saving it, and then running the sync. It worked fine in this case.
Tags: 
Salesforce, Quickbooks
Total votes: 606

with respect to above question please see below

The address you are passing in type-1
<BillAddress>
<Addr1>Company</Addr1>
<Addr2>Person Name</Addr2>
<Addr3>1234 Main St</Addr3>
<Addr4>Los Angeles, CA 90745</Addr4>
<Addr5>US</Addr5>
</BillAddress>

As you are entering the city,state postal code and country in the Address 4 and Address 5 you are getting this The first version gives the error: "The &quot;address&quot; field has an invalid value &quot;&quot;. QuickBooks error message: The parameter is incorrect." error.

That address 4 and 5 is reserved for street address.

In the mappings we have separate fields to map for city,state postal code and country,you can map ,provide value there.

The second error you are getting because in QuickBooks the Address is already entered in <BillAddress>
<Addr1>Company</Addr1>
<Addr2>Person Name</Addr2>
<Addr3>1234 Main St</Addr3>
<Addr4>Los Angeles, CA 90745</Addr4>
<Addr5>US</Addr5>
</BillAddress> in this format so when we tried to enter , we are getting that error.

To resolve this moving forward you can enter city,state postal code and country map separately and it will sync.

Total votes: 595

Thank you for your reply, Kishore.

This is not true: "That address 4 and 5 is reserved for street address."

Quickbooks addresses can be a maximum of 5 lines. So, if you were to use Addr1, Addr2, Addr3, Addr4, and Addr5 for the street address and then put the City, State, PostalCode, Country values in, it would be invalid. You can either use all 5 Addr fields, or you can use the first 3 Addr fields and the City, State, PostalCode, Country fields. Quickbooks addresses are strange in general: http://wiki.consolibyte.com/wiki/doku.php/quickbooks_qbxml_questions#is_...

You may have misread my post (it's hard for me to make it readable when normal users aren't allowed to use any formatting). My second example used the City, State, PostalCode, Country fields instead of Addr4 and Addr5. The error that it returned said that there aren't enough lines to compose the address. I think the issue is that when I submit the address the first time Quickbooks converts the City, State, PostalCode, Country values to Addr4 and Addr5, and since I can't submit an empty field in my request Quickbooks is keeping the existing Addr4 and Addr5 fields as they are. So, from Quickbooks' point of view, I'm trying to set the address to be this:

<Addr1>Company</Addr1>
<Addr2>Person Name</Addr2>
<Addr3>1234 Main St</Addr3>
<Addr4>Los Angeles, CA 90745</Addr4>
<Addr5>US</Addr5>
<City>Los Angeles</City>
<State>CA</State>
<PostalCode>90745</PostalCode>
<Country>US</Country>

Which is too big for Quickbooks and invalid.

To be clear, your suggestion ("To resolve this moving forward you can enter city,state postal code and country map separately and it will sync.") is what I already tried in my second example and it did not work.

Total votes: 652